---
id: CVE-2026-118095
title: >-
  WordPress Media LIbrary Assistant plugin <= 3.42 - Cross Site Scripting (XSS)
  vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in David Lingren Media LIbrary Assistant
  media-library-assistant allows DOM-Based XSS.This issue affects Media LIbrary
  Assistant: from n/a…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: David Lingren
product: media-library-assistant
affected:
  - media-library-assistant <= 3.42
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T14:34:20.555825Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T16:49:18.797Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118095'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/media-library-assistant/vulnerability/wordpress-media-library-assistant-plugin-3-42-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
epss: 0.00179
epssPercentile: 0.07506
ingestedAt: '2026-11-01T21:01:32.735Z'
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in David Lingren Media LIbrary Assistant media-library-assistant allows DOM-Based XSS.This issue affects Media LIbrary Assistant: from n/a through 3.42.

## Affected

- `media-library-assistant <= 3.42`

## Remediation

Update the WordPress Media LIbrary Assistant plugin to the latest available version (at least 3.43).
