---
id: CVE-2026-118097
title: >-
  WordPress Flash & HTML5 Video plugin <= 2.14.0 - Cross Site Scripting (XSS)
  vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in bPlugins Flash & HTML5 Video html5-video-player
  allows Stored XSS.This issue affects Flash & HTML5 Video: from n/a through
  2.14.0.
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: bPlugins
product: html5-video-player
affected:
  - html5-video-player <= 2.14.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T19:33:51.493751Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T19:34:06.345Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118097'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/html5-video-player/vulnerability/wordpress-flash-html5-video-plugin-2-14-0-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
epss: 0.0017
epssPercentile: 0.06318
ingestedAt: '2026-11-01T23:03:55.453Z'
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Flash & HTML5 Video html5-video-player allows Stored XSS.This issue affects Flash & HTML5 Video: from n/a through 2.14.0.

## Affected

- `html5-video-player <= 2.14.0`

## Remediation

Update the WordPress Flash & HTML5 Video plugin to the latest available version (at least 2.14.1).
