---
id: CVE-2026-118205
title: >-
  Essential Addons for Elementor <= 6.8.7 - Unauthenticated Privilege Escalation
  to 'page_id' Parameter via Elementor Revision
summary: >-
  The Essential Addons for Elementor – Popular Elementor Templates & Widgets
  plugin for WordPress is vulnerable to Privilege Escalation in all versions up
  to, and including, 6.8.7 via the `page_id` parameter of the `register_user()`
  functi…
severity: high
cvss: 7.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N'
cvssSource: cna
cwe:
  - CWE-269
vendor: wpdevteam
product: Essential Addons for Elementor – Popular Elementor Templates & Widgets
affected:
  - essential_addons_for_elementor_popular_elementor_templates_widgets <= 6.8.7
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-30T17:32:07.636874Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T18:08:57.942Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118205'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/a739cb9a-0b09-4303-8d4a-16fca1152adf?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/essential-addons-for-elementor-lite/tags/6.8.5/includes/Traits/Login_Registration.php#L1059
  - url: >-
      https://plugins.trac.wordpress.org/browser/essential-addons-for-elementor-lite/tags/6.8.5/includes/Traits/Login_Registration.php#L887
  - url: >-
      https://plugins.trac.wordpress.org/browser/essential-addons-for-elementor-lite/tags/6.8.5/includes/Traits/Login_Registration.php#L552
  - url: >-
      https://plugins.trac.wordpress.org/browser/essential-addons-for-elementor-lite/tags/6.8.5/includes/Traits/Login_Registration.php#L2762
  - url: >-
      https://plugins.trac.wordpress.org/browser/essential-addons-for-elementor-lite/tags/6.8.5/includes/Traits/Ajax_Handler.php#L1817
  - url: >-
      https://plugins.trac.wordpress.org/browser/essential-addons-for-elementor-lite/tags/6.8.5/includes/Classes/Bootstrap.php#L216
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3770535/essential-addons-for-elementor-lite/trunk/includes/Traits/Login_Registration.php
tags:
  - cve.org
epss: 0.00469
epssPercentile: 0.40686
ingestedAt: '2026-11-05T16:24:31.304Z'
---

## Overview

The Essential Addons for Elementor – Popular Elementor Templates & Widgets plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 6.8.7 via the `page_id` parameter of the `register_user()` function. The vulnerability exists because the handler's post status deny-list rejects `future`, `draft`, and `pending` but admits `inherit` — the status carried by every WordPress revision — allowing an attacker to substitute a revision ID for a live page ID, while a flawed "last saved by administrator" check reads `post_author` on revisions (which reflects the editing administrator) rather than the `_edit_last` meta that is never copied to revisions, and the nonce gate is rendered ineffective because any unauthenticated visitor can freely obtain a valid nonce via the `wp_ajax_nopriv_eael_get_token` endpoint. This makes it possible for unauthenticated attackers to register an account with a role as high as Editor — gaining capabilities including `edit_others_posts`, `publish_pages`, `upload_files`, and `unfiltered_html` — by naming a revision whose `_elementor_data` contains an elevated role an administrator previously saved and later reverted on a page bearing the Login/Register widget. Successful exploitation requires that the site has "Anyone can register" enabled and that an administrator has at some point saved and then reverted a non-default "New User Role" on an affected page.

## Affected

- `essential_addons_for_elementor_popular_elementor_templates_widgets <= 6.8.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
