---
id: CVE-2026-118558
title: Commerce Stripe - Critical - Cross-site request forgery - SA-CONTRIB-2026-263
summary: >-
  Cross-Site Request Forgery (CSRF) vulnerability in Drupal Commerce Stripe
  allows Cross Site Request Forgery. This issue affects Commerce Stripe
  versions: from 2.0.0 to 2.2.3.
severity: high
cvss: 7.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L'
cvssSource: adp
cwe:
  - CWE-352
vendor: Drupal
product: Commerce Stripe
affected:
  - commerce_stripe >= 2.0.0 < 2.2.3
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-11-06T13:43:46.054546Z'
published: '2026-10-30'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T13:45:27.837Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118558'
references:
  - url: 'https://www.drupal.org/sa-contrib-2026-263'
tags:
  - cve.org
epss: 0.00101
epssPercentile: 0.00915
ingestedAt: '2026-11-03T09:40:52.187Z'
---

## Overview

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Commerce Stripe allows Cross Site Request Forgery. This issue affects Commerce Stripe versions: from 2.0.0 to 2.2.3.

## Affected

- `commerce_stripe >= 2.0.0 < 2.2.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
