---
id: CVE-2026-118599
title: >-
  epiphany: TAR-based .xpi with hard links can overwrite user files during
  WebExtension install
summary: >-
  A file overwrite vulnerability exists in Epiphany when installing WebExtension
  packages from .xpi files.


  In src/webextension/ephy-web-extension-manager.c, decompress_xpi_thread() used
  libarchive with archive_read_support_format_all() (a…
severity: medium
cvss: 5.5
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N'
cvssSource: cna
cwe:
  - CWE-59
vendor: GNOME
product: epiphany
affected:
  - epiphany >= 47.0 < *
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-06T13:50:04.899341Z'
published: '2026-10-31'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T13:50:15.487Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118599'
references:
  - url: 'https://access.redhat.com/security/cve/CVE-2026-118599'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2562969'
    label: RHBZ#2562969
  - url: 'https://gitlab.gnome.org/GNOME/epiphany/-/work_items/2988'
  - url: 'https://gitlab.gnome.org/GNOME/epiphany/-/merge_requests/2248'
tags:
  - cve.org
epss: 0.00182
epssPercentile: 0.07812
ingestedAt: '2026-11-05T16:24:31.539Z'
---

## Overview

A file overwrite vulnerability exists in Epiphany when installing WebExtension packages from .xpi files.

In src/webextension/ephy-web-extension-manager.c, decompress_xpi_thread() used libarchive with archive_read_support_format_all() (and filters), so the installer did not require a real ZIP. A TAR file named *.xpi was extracted. TAR supports hard-link entry types; with Epiphany's archive_write_disk options (including ARCHIVE_EXTRACT_PERM), a crafted hard-link target can cause an attacker-chosen existing user-writable file to be truncated and overwritten with attacker-controlled content and mode bits, without a dedicated warning dialog, when the user installs or opens the crafted .xpi.

This is related to but separate from the ZIP-slip path traversal fixed as CVE-2026-77679 (#2922 / MR !2143).

Requirements: the victim must install or open a malicious WebExtension (.xpi).

Affected: Epiphany >= 47.0 (WebExtension XPI install path).
Fixed: https://gitlab.gnome.org/GNOME/epiphany/-/merge_requests/2248 (commit 0cc9ab55 — only enable ZIP format support).
Upstream: https://gitlab.gnome.org/GNOME/epiphany/-/work_items/2988
Reporter acknowledgment: Fernando Munoz

## Affected

- `epiphany >= 47.0 < *`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

### Workarounds

Do not install WebExtensions (.xpi) from untrusted sources. Prefer keeping WebExtensions disabled when unused (Epiphany can refuse install when the feature is disabled in recent fixes). After any untrusted .xpi install attempt, inspect unexpectedly modified user files (for example shell startup files, autostart desktop entries, or SSH authorized_keys). Upgrade to a fixed Epiphany build containing MR !2248 / commit 0cc9ab55 when available for your stream.
