---
id: CVE-2026-118635
title: >-
  GeoDirectory <= 2.8.198 - Unauthenticated Shortcode Injection via
  'pagination_info' Parameter
summary: >-
  The The GeoDirectory – WP Business Directory Plugin and Classified Listings
  Directory plugin for WordPress is vulnerable to arbitrary shortcode execution
  in all versions up to, and including, 2.8.198 This is due to the software
  allowing …
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-94
vendor: paoltaia
product: GeoDirectory – WP Business Directory Plugin and Classified Listings Directory
affected:
  - >-
    geodirectory_wp_business_directory_plugin_and_classified_listings_directory
    <= 2.8.198
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-30T17:34:06.270296Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T18:08:58.837Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118635'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/613531ba-0dbb-4c2d-9c40-e11f31cf4575?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.198/includes/widgets/class-geodir-widget-listings.php#L2044
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.198/includes/widgets/class-geodir-widget-listings.php#L2005
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.198/includes/widgets/class-geodir-widget-listings.php#L1171
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.198/includes/class-geodir-ajax.php#L1482
  - url: 'https://github.com/AyeCode/geodirectory/archive/refs/heads/master.zip'
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3773265/geodirectory/trunk/includes/widgets/class-geodir-widget-listings.php
tags:
  - cve.org
epss: 0.00435
epssPercentile: 0.37961
ingestedAt: '2026-11-05T16:24:31.309Z'
---

## Overview

The The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.8.198 This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.

## Affected

- `geodirectory_wp_business_directory_plugin_and_classified_listings_directory <= 2.8.198`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
