---
id: CVE-2026-118640
title: 'n8n before 1.123.85, 2.43.5, and 2.44.1 Chat Hub Authorization Bypass'
summary: >-
  n8n before 1.123.85, 2.43.5, and 2.44.1 contains an authorization bypass
  vulnerability in Chat Hub that allows chat-only users to register restricted
  tool types. Users with the global:chatUser role can add and run tools through
  chat to e…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-863
vendor: n8n-io
product: n8n
affected:
  - n8n < 1.123.85
  - n8n >= 2.44.0 < 2.44.1
  - n8n >= 2.0.0 < 2.43.5
published: '2026-10-28'
updated: '2026-10-28'
sourceUpdated: '2026-10-28T18:59:39.419Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118640'
references:
  - url: 'https://github.com/n8n-io/n8n/security/advisories/GHSA-43v8-hjhm-chjp'
    label: GitHub Security Advisory (GHSA-43v8-hjhm-chjp)
  - url: >-
      https://www.vulncheck.com/advisories/n8n-before-1.123.85-2.43.5-and-2.44.1-chat-hub-authorization-bypass
    label: >-
      VulnCheck Advisory: n8n before 1.123.85, 2.43.5, and 2.44.1 Chat Hub
      Authorization Bypass
tags:
  - cve.org
epss: 0.00189
epssPercentile: 0.08537
ingestedAt: '2026-10-29T15:37:07.527Z'
---

## Overview

n8n before 1.123.85, 2.43.5, and 2.44.1 contains an authorization bypass vulnerability in Chat Hub that allows chat-only users to register restricted tool types. Users with the global:chatUser role can add and run tools through chat to execute sandboxed code, access permitted files, and use instance workflows, Data Tables, and agents.

## Affected

- `n8n < 1.123.85`
- `n8n >= 2.44.0 < 2.44.1`
- `n8n >= 2.0.0 < 2.43.5`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
