---
id: CVE-2026-118668
title: LangGraph JavaScript custom authentication may permit cross-user Store access
summary: >-
  langgraph-api implements the LangGraph API for rapid development and testing.
  From 0.1.2 until 0.15.0, JavaScript or TypeScript custom authentication Store
  authorization handlers can return a rewritten namespace that is not carried
  acros…
severity: high
cvss: 8.6
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N'
cvssSource: cna
cwe:
  - CWE-639
  - CWE-863
vendor: langchain-ai
product: langgraph-api
affected:
  - 'langgraph-api >= 0.1.2, < 0.15.0'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-29T15:36:58.517052Z'
published: '2026-10-28'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T17:22:55.674Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118668'
references:
  - url: >-
      https://github.com/langchain-ai/langgraph/security/advisories/GHSA-4hm6-w6qq-w73v
    label: >-
      https://github.com/langchain-ai/langgraph/security/advisories/GHSA-4hm6-w6qq-w73v
  - url: 'https://github.com/advisories/GHSA-4hm6-w6qq-w73v'
  - url: 'https://github.com/langchain-ai/langgraph'
tags:
  - cve.org
  - ghsa
  - pip
  - osv
aliases:
  - GHSA-4hm6-w6qq-w73v
ecosystem: pip
patched:
  - langgraph-api 0.15.0
epss: 0.00369
epssPercentile: 0.30915
ingestedAt: '2026-10-28T21:18:49.939Z'
---

## Overview

langgraph-api implements the LangGraph API for rapid development and testing. From 0.1.2 until 0.15.0, JavaScript or TypeScript custom authentication Store authorization handlers can return a rewritten namespace that is not carried across the runtime boundary and applied before the Store operation. An authenticated user can therefore access another user's Store namespace when a deployment relies on namespace rewriting for isolation, allowing unauthorized reads, overwrites, searches, or deletions. Python custom authentication and handlers that reject unauthorized namespaces instead of rewriting them are not affected. This issue is fixed in version 0.15.0.

## Affected

- `langgraph-api >= 0.1.2, < 0.15.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-118668)

Affected packages:

- `langgraph-api >= 0.1.2, < 0.15.0`

Patched in:

- `langgraph-api 0.15.0`

Source: https://github.com/advisories/GHSA-4hm6-w6qq-w73v
