---
id: CVE-2026-118675
title: >-
  n8n before 1.123.85, 2.43.5, and 2.44.1 Credential Guard Bypass via Execute
  Sub-workflow
summary: >-
  n8n before 1.123.85, 2.43.5, and 2.44.1 contains a credential guard bypass
  vulnerability that allows editors of shared workflows to use restricted
  credentials by loading sub-workflows from URLs or local files. Attackers can
  configure the…
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-863
vendor: n8n-io
product: n8n
affected:
  - n8n < 1.123.85
  - n8n >= 2.44.0 < 2.44.1
  - n8n >= 2.0.0 < 2.43.5
published: '2026-10-28'
updated: '2026-10-28'
sourceUpdated: '2026-10-28T18:59:48.389Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118675'
references:
  - url: 'https://github.com/n8n-io/n8n/security/advisories/GHSA-8crx-5h96-q72q'
    label: GitHub Security Advisory (GHSA-8crx-5h96-q72q)
  - url: >-
      https://www.vulncheck.com/advisories/n8n-before-1.123.85-2.43.5-and-2.44.1-credential-guard-bypass-via-execute-sub-workflow
    label: >-
      VulnCheck Advisory: n8n before 1.123.85, 2.43.5, and 2.44.1 Credential
      Guard Bypass via Execute Sub-workflow
tags:
  - cve.org
epss: 0.00171
epssPercentile: 0.0647
ingestedAt: '2026-10-29T15:37:07.546Z'
---

## Overview

n8n before 1.123.85, 2.43.5, and 2.44.1 contains a credential guard bypass vulnerability that allows editors of shared workflows to use restricted credentials by loading sub-workflows from URLs or local files. Attackers can configure the Execute Sub-workflow node with source url or localFile to serve content that resolves project credentials and returns their decrypted values.

## Affected

- `n8n < 1.123.85`
- `n8n >= 2.44.0 < 2.44.1`
- `n8n >= 2.0.0 < 2.43.5`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
