---
id: CVE-2026-118676
title: 'n8n before 1.123.85, 2.43.5, and 2.44.1 Credential Permission Check Bypass'
summary: >-
  n8n before 1.123.85, 2.43.5, and 2.44.1 contains an authorization bypass
  vulnerability that allows member users to use credentials they cannot access
  by omitting default node parameters. Attackers can save and run workflows
  where pre-exe…
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-863
vendor: n8n-io
product: n8n
affected:
  - n8n < 1.123.85
  - n8n >= 2.44.0 < 2.44.1
  - n8n >= 2.0.0 < 2.43.5
published: '2026-10-28'
updated: '2026-10-28'
sourceUpdated: '2026-10-28T18:59:49.071Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118676'
references:
  - url: 'https://github.com/n8n-io/n8n/security/advisories/GHSA-v9cx-v88r-42vw'
    label: GitHub Security Advisory (GHSA-v9cx-v88r-42vw)
  - url: >-
      https://www.vulncheck.com/advisories/n8n-before-1.123.85-2.43.5-and-2.44.1-credential-permission-check-bypass
    label: >-
      VulnCheck Advisory: n8n before 1.123.85, 2.43.5, and 2.44.1 Credential
      Permission Check Bypass
tags:
  - cve.org
epss: 0.002
epssPercentile: 0.09806
ingestedAt: '2026-10-29T15:37:07.547Z'
---

## Overview

n8n before 1.123.85, 2.43.5, and 2.44.1 contains an authorization bypass vulnerability that allows member users to use credentials they cannot access by omitting default node parameters. Attackers can save and run workflows where pre-execution checks skip credential slots, causing decrypted credential values to be sent to attacker-chosen destinations.

## Affected

- `n8n < 1.123.85`
- `n8n >= 2.44.0 < 2.44.1`
- `n8n >= 2.0.0 < 2.43.5`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
