---
id: CVE-2026-118687
title: >-
  Coder before 2.29.21, 2.34.12, 2.35.9, 2.36.7, and 2.37.4 Missing Audience
  Validation in GCP Instance-Identity Authentication
summary: >-
  Coder before 2.29.21, 2.30.0 before 2.34.12, 2.35.0 before 2.35.9, 2.36.0
  before 2.36.7, and 2.37.0 before 2.37.4 does not validate the audience claim
  of GCE instance-identity JWTs at the POST
  /api/v2/workspaceagents/google-instance-iden…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-441
vendor: coder
product: coder
affected:
  - coder >= 2.37.0 < 2.37.4
  - coder >= 2.36.0 < 2.36.7
  - coder >= 2.35.0 < 2.35.9
  - coder >= 2.30.0 < 2.34.12
  - coder < 2.29.21
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T15:28:59.226439Z'
published: '2026-10-28'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T20:54:16.473Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118687'
references:
  - url: 'https://github.com/coder/coder/security/advisories/GHSA-24vh-q7rg-243w'
    label: GitHub Security Advisory (GHSA-24vh-q7rg-243w)
  - url: >-
      https://www.vulncheck.com/advisories/coder-before-2.29.21-2.34.12-2.35.9-2.36.7-and-2.37.4-missing-audience-validation-in-gcp-instance-identity-authentication
    label: >-
      VulnCheck Advisory: Coder before 2.29.21, 2.34.12, 2.35.9, 2.36.7, and
      2.37.4 Missing Audience Validation in GCP Instance-Identity Authentication
tags:
  - cve.org
epss: 0.00186
epssPercentile: 0.08226
ingestedAt: '2026-10-29T15:37:07.553Z'
---

## Overview

Coder before 2.29.21, 2.30.0 before 2.34.12, 2.35.0 before 2.35.9, 2.36.0 before 2.36.7, and 2.37.0 before 2.37.4 does not validate the audience claim of GCE instance-identity JWTs at the POST /api/v2/workspaceagents/google-instance-identity endpoint. Attackers who obtain an unexpired format=full identity token minted for another relying party can replay it to obtain that workspace agent's session token, which remains valid until the workspace's next build.

## Affected

- `coder >= 2.37.0 < 2.37.4`
- `coder >= 2.36.0 < 2.36.7`
- `coder >= 2.35.0 < 2.35.9`
- `coder >= 2.30.0 < 2.34.12`
- `coder < 2.29.21`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
