---
id: CVE-2026-119129
title: >-
  ZITADEL 3.0.0 through 3.4.15 and 4.0.0 before 4.19.5 Account Takeover via
  Device Authorization Approval
summary: >-
  ZITADEL 3.0.0 through 3.4.15 and 4.0.0 before 4.19.5 contains a missing
  authorization vulnerability in Login V2 that allows attackers to approve OAuth
  2.0 device authorizations using a victim's existing session without consent.
  Attackers…
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N'
cvssSource: cna
cwe:
  - CWE-862
vendor: zitadel
product: zitadel
affected:
  - zitadel >= 4.0.0 < 4.19.5
  - zitadel >= 3.0.0 <= 3.4.15
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-29T17:12:08.195339Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T17:14:47.873Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119129'
references:
  - url: 'https://github.com/zitadel/zitadel/security/advisories/GHSA-qj3q-235g-qr6w'
    label: GitHub Security Advisory (GHSA-qj3q-235g-qr6w)
  - url: >-
      https://www.vulncheck.com/advisories/zitadel-3.0.0-through-3.4.15-and-4.0.0-before-4.19.5-account-takeover-via-device-authorization-approval
    label: >-
      VulnCheck Advisory: ZITADEL 3.0.0 through 3.4.15 and 4.0.0 before 4.19.5
      Account Takeover via Device Authorization Approval
tags:
  - cve.org
epss: 0.00284
epssPercentile: 0.20934
ingestedAt: '2026-11-01T21:01:32.750Z'
---

## Overview

ZITADEL 3.0.0 through 3.4.15 and 4.0.0 before 4.19.5 contains a missing authorization vulnerability in Login V2 that allows attackers to approve OAuth 2.0 device authorizations using a victim's existing session without consent. Attackers can send a signed-in user a link carrying the attacker's user code to obtain the victim's tokens, and can bypass project access settings via the OIDC device authorization API.

## Affected

- `zitadel >= 4.0.0 < 4.19.5`
- `zitadel >= 3.0.0 <= 3.4.15`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
