---
id: CVE-2026-119160
title: >-
  Smart Post <= 4.0.9 - Authenticated (Subscriber+) Stored Cross-Site Scripting
  via User display_name via Author Filter block
summary: >-
  The Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for
  Blog & News plugin for WordPress is vulnerable to Stored Cross-Site Scripting
  via the 'display_name' parameter in all versions up to, and including, 4.0.9
  due to…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: shapedplugin
product: >-
  Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for Blog &
  News
affected:
  - >-
    smart_post_post_grid_post_carousel_post_slider_gutenberg_blocks_for_blog_news
    <= 4.0.9
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-01T17:34:10.225719Z'
published: '2026-10-31'
updated: '2026-11-01'
sourceUpdated: '2026-11-01T17:34:19.085Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119160'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/a5612c16-9629-4869-8ec1-8fba788b7d7c?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-carousel/tags/4.0.8/blocks/includes/class-template-part.php#L1146
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-carousel/tags/4.0.8/blocks/assets/js/script.js#L1744
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-carousel/tags/4.0.8/blocks/includes/class-template-part.php#L1130
  - url: 'https://plugins.trac.wordpress.org/changeset/3775298/post-carousel'
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3775298/post-carousel/trunk/blocks/assets/js/script.js
tags:
  - cve.org
epss: 0.00234
epssPercentile: 0.14369
ingestedAt: '2026-11-05T18:28:50.811Z'
---

## Overview

The Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for Blog & News plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name' parameter in all versions up to, and including, 4.0.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the victim page to contain an Author Filter block alongside a grid or live-filter block, and execution is triggered by a visitor clicking the attacker's author entry in the dropdown — a standard filter interaction requiring no elevated privileges from the victim.

## Affected

- `smart_post_post_grid_post_carousel_post_slider_gutenberg_blocks_for_blog_news <= 4.0.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
