---
id: CVE-2026-119176
title: >-
  CP Multi View Events Calendar <= 1.4.43 - Authenticated (Subscriber+) Stored
  Cross-Site Scripting via 'Subject' Parameter
summary: >-
  The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via the 'Subject' parameter in all versions up to, and
  including, 1.4.43 due to insufficient input sanitization and output escaping.
  This…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: codepeople
product: CP Multi View Events Calendar
affected:
  - cp_multi_view_events_calendar <= 1.4.43
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T17:32:30.229563Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T18:08:59.759Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119176'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/026ce95f-3fa4-43d3-b786-1c379a210b50?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.43/DC_MultiViewCal/src/Plugins/jquery.calendar.js#L2938
  - url: >-
      https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.43/DC_MultiViewCal/src/Plugins/jquery.calendar.js#L2865
  - url: >-
      https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.43/DC_MultiViewCal/src/Plugins/jquery.calendar.js#L2293
  - url: >-
      https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.43/php/datafeed.php#L61
  - url: >-
      https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.43/php/datafeed.php#L79
  - url: 'https://plugins.trac.wordpress.org/log/cp-multi-view-calendar/'
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3774063/cp-multi-view-calendar/trunk/DC_MultiViewCal/src/Plugins/jquery.calendar.js
tags:
  - cve.org
epss: 0.0032
epssPercentile: 0.25074
ingestedAt: '2026-11-05T16:24:31.310Z'
---

## Overview

The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Subject' parameter in all versions up to, and including, 1.4.43 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The required nonce is localized to any published page carrying the calendar shortcode, making the adddetails endpoint reachable by any authenticated user with Subscriber-level access or above.

## Affected

- `cp_multi_view_events_calendar <= 1.4.43`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
