---
id: CVE-2026-119369
title: >-
  WordPress The Events Calendar plugin <= 6.18.2 - Cross Site Scripting (XSS)
  vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in Liquid Web / StellarWP The Events Calendar
  the-events-calendar allows Stored XSS.This issue affects The Events Calendar:
  from n/a throu…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: Liquid Web / StellarWP
product: the-events-calendar
affected:
  - the-events-calendar <= 6.18.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T15:43:29.685415Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T15:43:43.340Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119369'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/the-events-calendar/vulnerability/wordpress-the-events-calendar-plugin-6-18-2-cross-site-scripting-xss-vulnerability-2?_s_id=cve
tags:
  - cve.org
epss: 0.00217
epssPercentile: 0.12243
ingestedAt: '2026-11-05T16:07:30.463Z'
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Liquid Web / StellarWP The Events Calendar the-events-calendar allows Stored XSS.This issue affects The Events Calendar: from n/a through 6.18.2.

## Affected

- `the-events-calendar <= 6.18.2`

## Remediation

Update the WordPress The Events Calendar plugin to the latest available version (at least 6.18.3).
