---
id: CVE-2026-119371
title: SQLite before 3.54.0 Stack Exhaustion via CTE Chain in selectExpander()
summary: >-
  SQLite before 3.54.0 contains a stack exhaustion vulnerability that allows
  attackers to bypass the SQLITE_LIMIT_EXPR_DEPTH nesting limit because common
  table expressions are not counted against it. Attackers can supply a WITH
  clause chai…
severity: medium
cvss: 5.5
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-674
vendor: SQLite
product: SQLite
affected:
  - SQLite < 3.54.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T15:50:50.830999Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T15:51:05.359Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119371'
references:
  - url: 'https://sqlite.org/bugs/info/2026-10-04T04:58:58Z'
  - url: 'https://sqlite.org/src/info/f54730871303e655'
  - url: >-
      https://github.com/sqlite/sqlite/commit/e6ff280c839fdfc7418fd5add12e8f32702a17fb
  - url: 'https://github.com/sqlite/sqlite/blob/version-3.53.4/src/select.c#L5754'
  - url: 'https://sqlite.org/releaselog/3_54_0.html'
  - url: 'https://abraxaslabs.tech/research/sqlite-cte-nest'
  - url: 'https://github.com/sqlite/sqlite'
  - url: >-
      https://www.vulncheck.com/advisories/sqlite-before-3.54.0-stack-exhaustion-via-cte-chain-in-selectexpander
    label: >-
      VulnCheck Advisory: SQLite before 3.54.0 Stack Exhaustion via CTE Chain in
      selectExpander()
tags:
  - cve.org
epss: 0.00191
epssPercentile: 0.08838
ingestedAt: '2026-11-05T16:07:30.489Z'
---

## Overview

SQLite before 3.54.0 contains a stack exhaustion vulnerability that allows attackers to bypass the SQLITE_LIMIT_EXPR_DEPTH nesting limit because common table expressions are not counted against it. Attackers can supply a WITH clause chaining tens of thousands of CTEs, via plain SQL or a view in an untrusted database file, causing unbounded selectExpander() recursion that crashes the process.

## Affected

- `SQLite < 3.54.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
