---
id: CVE-2026-119426
title: phpMyAdmin through 5.2.3 CSRF Token Bypass via Non-AJAX POST to /sql
summary: >-
  phpMyAdmin through 5.2.3 contains a cross-site request forgery vulnerability
  that allows remote attackers to execute arbitrary SQL by bypassing CSRF token
  checks on non-AJAX POST requests. Attackers can lure authenticated victims
  into su…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-352
vendor: phpMyAdmin
product: phpMyAdmin
affected:
  - phpMyAdmin <= 5.2.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-30T16:06:14.646686Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T16:06:24.241Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119426'
references:
  - url: >-
      https://github.com/phpmyadmin/phpmyadmin/commit/d1e2b54b530685c24dd91181b9f64a5a64621789
  - url: >-
      https://github.com/phpmyadmin/phpmyadmin/commit/910322373f14ed4601c85234858f630f127569ef
  - url: 'https://github.com/phpmyadmin/phpmyadmin/pull/20569'
  - url: >-
      https://github.com/phpmyadmin/phpmyadmin/blob/RELEASE_5_2_3/libraries/classes/Common.php#L87-L151
  - url: 'https://abraxaslabs.tech/research/phpmyadmin-csrf-sql'
  - url: 'https://github.com/phpmyadmin/phpmyadmin'
  - url: >-
      https://www.vulncheck.com/advisories/phpmyadmin-through-5.2.3-csrf-token-bypass-via-non-ajax-post-to-sql
    label: >-
      VulnCheck Advisory: phpMyAdmin through 5.2.3 CSRF Token Bypass via
      Non-AJAX POST to /sql
tags:
  - cve.org
epss: 0.00351
epssPercentile: 0.28885
ingestedAt: '2026-11-05T16:24:31.054Z'
---

## Overview

phpMyAdmin through 5.2.3 contains a cross-site request forgery vulnerability that allows remote attackers to execute arbitrary SQL by bypassing CSRF token checks on non-AJAX POST requests. Attackers can lure authenticated victims into submitting cross-site POSTs carrying sql_query to /sql or /database/sql, running SQL with the victim's database privileges under http or config authentication.

## Affected

- `phpMyAdmin <= 5.2.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
