---
id: CVE-2026-119488
title: >-
  WordPress Pie Register plugin <= 3.8.4.15 - Cross Site Scripting (XSS)
  vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in Shamim Rajani Pie Register pie-register allows
  Stored XSS.This issue affects Pie Register: from n/a through 3.8.4.15.
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: Shamim Rajani
product: pie-register
affected:
  - pie-register <= 3.8.4.15
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-06T14:59:42.997905Z'
published: '2026-11-06'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T15:04:31.805Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119488'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/pie-register/vulnerability/wordpress-pie-register-plugin-3-8-4-15-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
epss: 0.0018
epssPercentile: 0.07615
ingestedAt: '2026-11-06T08:48:01.706Z'
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Shamim Rajani Pie Register pie-register allows Stored XSS.This issue affects Pie Register: from n/a through 3.8.4.15.

## Affected

- `pie-register <= 3.8.4.15`

## Remediation

Update the WordPress Pie Register plugin to the latest available version (at least 3.8.4.16).
