---
id: CVE-2026-119553
title: >-
  Moodle through 5.3.0, 5.2.4, 5.1.8, 5.0.11 and 4.5.15 Blackboard Import Path
  Traversal
summary: >-
  Moodle 5.3.0, 5.2.0 through 5.2.4, 5.1.0 through 5.1.8, 5.0.0 through 5.0.11,
  and through 4.5.15 contains a path traversal vulnerability in the Blackboard
  question import format. Teachers with question import or lesson edit rights
  can up…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-23
vendor: Moodle Project
product: moodle
affected:
  - moodle 5.3.0
  - moodle >= 5.2.0 <= 5.2.4
  - moodle >= 5.1.0 <= 5.1.8
  - moodle >= 5.0.0 <= 5.0.11
  - moodle <= 4.5.15
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T16:11:56.914069Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T16:12:09.728Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119553'
references:
  - url: >-
      https://github.com/moodle/moodle/blob/v5.3.0/public/question/format/blackboard_six/formatbase.php#L128-L133
  - url: 'https://abraxaslabs.tech/research/moodle-blackboard-img'
  - url: 'https://github.com/moodle/moodle'
  - url: >-
      https://www.vulncheck.com/advisories/moodle-through-5.3.0-5.2.4-5.1.8-5.0.11-and-4.5.15-blackboard-import-path-traversal
    label: >-
      VulnCheck Advisory: Moodle through 5.3.0, 5.2.4, 5.1.8, 5.0.11 and 4.5.15
      Blackboard Import Path Traversal
tags:
  - cve.org
epss: 0.00419
epssPercentile: 0.36338
ingestedAt: '2026-11-05T16:24:31.062Z'
---

## Overview

Moodle 5.3.0, 5.2.0 through 5.2.4, 5.1.0 through 5.1.8, 5.0.0 through 5.0.11, and through 4.5.15 contains a path traversal vulnerability in the Blackboard question import format. Teachers with question import or lesson edit rights can upload a crafted zip with img src values containing ../ sequences, copying server files like config.php into their draft area.

## Affected

- `moodle 5.3.0`
- `moodle >= 5.2.0 <= 5.2.4`
- `moodle >= 5.1.0 <= 5.1.8`
- `moodle >= 5.0.0 <= 5.0.11`
- `moodle <= 4.5.15`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
