---
id: CVE-2026-119560
title: >-
  OPNsense core through 26.7.8 NTP Configuration Injection via GPS and PPS Fudge
  Fields
summary: >-
  OPNsense core through 26.7.8 contains a configuration injection vulnerability
  that allows authenticated users to append ntpd.conf directives by embedding
  newlines in the fudge and refid fields. Attackers holding the
  page-services-ntp-gps…
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:L'
cvssSource: cna
cwe:
  - CWE-93
vendor: opnsense
product: core
affected:
  - core <= 26.7.8
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T15:21:08.046274Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T15:54:16.495Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119560'
references:
  - url: >-
      https://github.com/opnsense/core/blob/26.7.8/src/etc/inc/plugins.inc.d/ntpd.inc#L285-L312
  - url: >-
      https://github.com/opnsense/core/blob/26.7.8/src/www/services_ntpd_gps.php#L49
  - url: 'https://github.com/opnsense/core/security/advisories/GHSA-fq94-cxvc-9r7w'
    label: GitHub Security Advisory (GHSA-fq94-cxvc-9r7w)
  - url: 'https://abraxaslabs.tech/research/opnsense-ntp-gps-fudge'
  - url: 'https://github.com/opnsense/core'
  - url: >-
      https://www.vulncheck.com/advisories/opnsense-core-through-26.7.8-ntp-configuration-injection-via-gps-and-pps-fudge-fields
    label: >-
      VulnCheck Advisory: OPNsense core through 26.7.8 NTP Configuration
      Injection via GPS and PPS Fudge Fields
tags:
  - cve.org
epss: 0.00344
epssPercentile: 0.28078
ingestedAt: '2026-11-05T16:07:30.522Z'
---

## Overview

OPNsense core through 26.7.8 contains a configuration injection vulnerability that allows authenticated users to append ntpd.conf directives by embedding newlines in the fudge and refid fields. Attackers holding the page-services-ntp-gps or PPS privilege can submit CR/LF characters via services_ntpd_gps.php or services_ntpd_pps.php to inject directives loaded by ntpd running as root.

## Affected

- `core <= 26.7.8`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
