---
id: CVE-2026-119561
title: >-
  phpMyAdmin through 5.2.3 WebAuthn Two-Factor Authentication Bypass via
  CustomServer
summary: >-
  phpMyAdmin through 5.2.3 contains an authentication bypass vulnerability in
  CustomServer::parseAndValidateAssertionResponse() that never verifies WebAuthn
  assertion signatures against stored public keys. Attackers holding a victim's
  MySQ…
severity: medium
cvss: 6.8
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N'
cvssSource: cna
cwe:
  - CWE-347
vendor: phpMyAdmin
product: phpMyAdmin
affected:
  - phpMyAdmin <= 5.2.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-30T16:21:10.400395Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T16:21:29.456Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119561'
references:
  - url: >-
      https://github.com/phpmyadmin/phpmyadmin/blob/RELEASE_5_2_3/libraries/classes/WebAuthn/CustomServer.php#L76-L110
  - url: 'https://abraxaslabs.tech/research/PMA-5.2.3-WebAuthn-2FA'
  - url: 'https://abraxaslabs.tech/research/phpmyadmin-webauthn'
  - url: 'https://github.com/phpmyadmin/phpmyadmin'
  - url: >-
      https://www.vulncheck.com/advisories/phpmyadmin-through-5.2.3-webauthn-two-factor-authentication-bypass-via-customserver
    label: >-
      VulnCheck Advisory: phpMyAdmin through 5.2.3 WebAuthn Two-Factor
      Authentication Bypass via CustomServer
tags:
  - cve.org
epss: 0.00204
epssPercentile: 0.10473
ingestedAt: '2026-11-05T16:24:31.074Z'
---

## Overview

phpMyAdmin through 5.2.3 contains an authentication bypass vulnerability in CustomServer::parseAndValidateAssertionResponse() that never verifies WebAuthn assertion signatures against stored public keys. Attackers holding a victim's MySQL credentials can POST a crafted webauthn_request_response with matching challenge, origin, and rpIdHash to bypass the second factor and gain database privileges.

## Affected

- `phpMyAdmin <= 5.2.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
