---
id: CVE-2026-119571
title: >-
  Parse Server 9.7.0 before 9.10.5-alpha.10 Installation Update Misdirection via
  Installation ID
summary: >-
  Parse Server from 9.7.0 before 9.10.5-alpha.10 contains an authorization flaw
  that applies _Installation updates addressed by object ID to the installation
  named in the X-Parse-Installation-Id header. When protectedFieldsTriggerExempt
  is…
severity: low
cvss: 3.7
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-639
vendor: parse-community
product: parse-server
affected:
  - parse-server >= 9.7.0 < 9.10.5-alpha.10
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-04T22:24:16.913784Z'
published: '2026-10-30'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T22:24:28.220Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119571'
references:
  - url: >-
      https://github.com/parse-community/parse-server/security/advisories/GHSA-8j8q-73xx-w3m4
    label: GitHub Security Advisory (GHSA-8j8q-73xx-w3m4)
  - url: >-
      https://www.vulncheck.com/advisories/parse-server-9.7.0-before-9.10.5-alpha.10-installation-update-misdirection-via-installation-id
    label: >-
      VulnCheck Advisory: Parse Server 9.7.0 before 9.10.5-alpha.10 Installation
      Update Misdirection via Installation ID
tags:
  - cve.org
epss: 0.00219
epssPercentile: 0.12435
ingestedAt: '2026-11-05T21:36:00.642Z'
---

## Overview

Parse Server from 9.7.0 before 9.10.5-alpha.10 contains an authorization flaw that applies _Installation updates addressed by object ID to the installation named in the X-Parse-Installation-Id header. When protectedFieldsTriggerExempt is enabled, attackers knowing another installation's object ID can make a beforeSave trigger process that installation's protected fields while writing elsewhere.

## Affected

- `parse-server >= 9.7.0 < 9.10.5-alpha.10`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
