---
id: CVE-2026-119714
title: >-
  My Calendar 3.8.8 before 3.8.11 Unauthenticated Shortcode Injection via mcs
  Parameter
summary: >-
  My Calendar WordPress plugin 3.8.8 before 3.8.11 contains a shortcode
  injection vulnerability that allows unauthenticated attackers to execute
  registered shortcodes via the mcs search parameter. The mcs value reaches
  mc_search_results() …
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-94
vendor: joedolson
product: My Calendar - Accessible Event Manager
affected:
  - my_calendar_-_accessible_event_manager >= 3.8.8 < 3.8.11
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-30T15:41:43.334329Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T15:42:00.197Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119714'
references:
  - url: >-
      https://github.com/joedolson/my-calendar/commit/de875c25d9651abb041b2dfe32f60a4320c66496
    label: Patch Commit
  - url: 'https://github.com/joedolson/my-calendar'
  - url: 'https://github.com/joedolson/my-calendar/releases/tag/v3.8.11'
    label: My Calendar - Accessible Event Manager v3.8.11 Release Notes
  - url: >-
      https://github.com/joedolson/my-calendar/blob/v3.8.10/src/my-calendar-search.php#L170
  - url: >-
      https://www.vulncheck.com/advisories/my-calendar-3.8.8-before-3.8.11-unauthenticated-shortcode-injection-via-mcs-parameter
    label: >-
      VulnCheck Advisory: My Calendar 3.8.8 before 3.8.11 Unauthenticated
      Shortcode Injection via mcs Parameter
tags:
  - cve.org
epss: 0.00309
epssPercentile: 0.23881
ingestedAt: '2026-11-05T16:07:30.456Z'
---

## Overview

My Calendar WordPress plugin 3.8.8 before 3.8.11 contains a shortcode injection vulnerability that allows unauthenticated attackers to execute registered shortcodes via the mcs search parameter. The mcs value reaches mc_search_results() in src/my-calendar-search.php without bracket encoding before do_shortcode runs, so a GET request triggers shortcodes on any page or post, enabling content injection and spoofing.

## Affected

- `my_calendar_-_accessible_event_manager >= 3.8.8 < 3.8.11`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
