---
id: CVE-2026-119719
title: >-
  Blender before 4.5.15 and 5.x before 5.2.3 Heap Buffer Overflow via Thumbnail
  Extraction
summary: >-
  Blender before 4.5.15 and 5.x before 5.2.3 contains a heap buffer overflow
  vulnerability in the blend file thumbnail extractor caused by 32-bit integer
  overflow in thumb_data_vertical_flip(). Attackers can craft a .blend file with
  malici…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-190
vendor: Blender Foundation
product: Blender
affected:
  - Blender < 4.5.15
  - Blender >= 5.0.0 < 5.2.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-11-04T22:55:50.193042Z'
published: '2026-10-30'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T22:56:02.873Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119719'
references:
  - url: 'https://projects.blender.org/blender/blender/pulls/164279'
  - url: >-
      https://projects.blender.org/blender/blender/commit/d723c68112d216099c9b24dab5c8440bab7add08
  - url: >-
      https://projects.blender.org/blender/blender/commit/71c10a0217d5e331b215b76773ad23b64974bd97
  - url: 'https://projects.blender.org/blender/blender'
  - url: >-
      https://www.vulncheck.com/advisories/blender-before-4.5.15-and-5-x-before-5.2.3-heap-buffer-overflow-via-thumbnail-extraction
    label: >-
      VulnCheck Advisory: Blender before 4.5.15 and 5.x before 5.2.3 Heap Buffer
      Overflow via Thumbnail Extraction
tags:
  - cve.org
epss: 0.00156
epssPercentile: 0.048
ingestedAt: '2026-11-05T21:36:00.666Z'
---

## Overview

Blender before 4.5.15 and 5.x before 5.2.3 contains a heap buffer overflow vulnerability in the blend file thumbnail extractor caused by 32-bit integer overflow in thumb_data_vertical_flip(). Attackers can craft a .blend file with malicious TEST block dimensions that trigger an out-of-bounds write when blender-thumbnailer or the Windows shell extension previews it, causing crashes or code execution.

## Affected

- `Blender < 4.5.15`
- `Blender >= 5.0.0 < 5.2.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
