---
id: CVE-2026-119721
title: >-
  Blender before 4.5.15 and 5.x before 5.2.3 Out-of-Bounds Read via blo_bhead_id
  Accessors
summary: >-
  Blender before 4.5.15 and 5.x before 5.2.3 contains an out-of-bounds read
  vulnerability in blo_bhead_id_* accessors in readfile.cc that read ID fields
  without block length checks. Attackers can supply a crafted .blend file with
  short ID …
severity: medium
cvss: 6.1
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-125
vendor: Blender Foundation
product: Blender
affected:
  - Blender < 4.5.15
  - Blender >= 5.0.0 < 5.2.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T18:25:13.808921Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T18:36:11.655Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119721'
references:
  - url: 'https://projects.blender.org/blender/blender/pulls/164279'
  - url: >-
      https://projects.blender.org/blender/blender/commit/c5d6faf04bf3f17efb6c404896ef0e7427784da5
  - url: >-
      https://projects.blender.org/blender/blender/commit/7de4986e74ed47f67e78eb4b76609bb6d1ae8a0e
  - url: >-
      https://projects.blender.org/blender/blender/commit/495deb9efff880c42aa88110aec0ea2c0fb1eb07
  - url: >-
      https://projects.blender.org/blender/blender/commit/94d99b362b0d236dcf07a96c1c8f9f5389d0583c
  - url: 'https://projects.blender.org/blender/blender'
  - url: >-
      https://www.vulncheck.com/advisories/blender-before-4.5.15-and-5-x-before-5.2.3-out-of-bounds-read-via-blo-bhead-id-accessors
    label: >-
      VulnCheck Advisory: Blender before 4.5.15 and 5.x before 5.2.3
      Out-of-Bounds Read via blo_bhead_id Accessors
tags:
  - cve.org
epss: 0.00168
epssPercentile: 0.06234
ingestedAt: '2026-11-05T16:24:31.335Z'
---

## Overview

Blender before 4.5.15 and 5.x before 5.2.3 contains an out-of-bounds read vulnerability in blo_bhead_id_* accessors in readfile.cc that read ID fields without block length checks. Attackers can supply a crafted .blend file with short ID blocks that, when browsed or appended from, causes heap over-reads leading to crashes or heap memory disclosure.

## Affected

- `Blender < 4.5.15`
- `Blender >= 5.0.0 < 5.2.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
