---
id: CVE-2026-119747
title: GetPaid WordPress Plugin < 2.8.63 Incorrect Authorization via REST API
summary: >-
  The GetPaid plugin for WordPress before 2.8.63 contains an incorrect
  authorization vulnerability where the check_post_permissions() method in
  includes/api/class-getpaid-rest-posts-controller.php maps REST operations to
  generic WordPress …
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N'
cvssSource: cna
cwe:
  - CWE-863
vendor: AyeCode Ltd
product: 'Payment forms, Buy now buttons, and Invoicing System | GetPaid'
affected:
  - payment_forms_buy_now_buttons_and_invoicing_system_getpaid < 2.8.63
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-04T20:22:35.412759Z'
published: '2026-11-04'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T20:24:14.905Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119747'
references:
  - url: 'https://wordpress.org/plugins/invoicing/#developers'
    label: WordPress Changelog
  - url: >-
      https://www.vulncheck.com/advisories/getpaid-wordpress-plugin-incorrect-authorization-via-rest-api
    label: >-
      VulnCheck Advisory: GetPaid WordPress Plugin < 2.8.63 Incorrect
      Authorization via REST API
tags:
  - cve.org
ingestedAt: '2026-11-05T21:36:00.549Z'
---

## Overview

The GetPaid plugin for WordPress before 2.8.63 contains an incorrect authorization vulnerability where the check_post_permissions() method in includes/api/class-getpaid-rest-posts-controller.php maps REST operations to generic WordPress post capabilities instead of enforcing the plugin's manage_invoicing permission. Authenticated users with lower-privileged roles such as Editor or Author can exploit this flaw to list other users' invoices, mark pending invoices as paid without recording payment transactions, or create published items and new invoices through the REST API.

## Affected

- `payment_forms_buy_now_buttons_and_invoicing_system_getpaid < 2.8.63`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
