---
id: CVE-2026-119748
title: GetPaid WordPress Plugin < 2.8.63 Authorization Bypass via maybe_use_invoice
summary: >-
  The GetPaid plugin for WordPress before 2.8.63 contains an authorization
  bypass vulnerability that allows unauthenticated attackers to access and
  manipulate another user's invoice by supplying its ID through the
  maybe_use_invoice paramet…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-639
vendor: AyeCode Ltd
product: 'Payment forms, Buy now buttons, and Invoicing System | GetPaid'
affected:
  - payment_forms_buy_now_buttons_and_invoicing_system_getpaid < 2.8.63
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-11-04T20:24:43.578506Z'
published: '2026-11-04'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T20:25:07.989Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-119748'
references:
  - url: 'https://wordpress.org/plugins/invoicing/#developers'
    label: WordPress Changelog
  - url: >-
      https://www.vulncheck.com/advisories/getpaid-wordpress-plugin-authorization-bypass-via-maybe-use-invoice
    label: >-
      VulnCheck Advisory: GetPaid WordPress Plugin < 2.8.63 Authorization Bypass
      via maybe_use_invoice
tags:
  - cve.org
ingestedAt: '2026-11-05T21:36:00.552Z'
---

## Overview

The GetPaid plugin for WordPress before 2.8.63 contains an authorization bypass vulnerability that allows unauthenticated attackers to access and manipulate another user's invoice by supplying its ID through the maybe_use_invoice parameter in process_invoice(), bypassing the ownership and key checks performed by is_authorized_to_pay(). Attackers can submit a known pending invoice ID via maybe_use_invoice to read checkout pricing details and initiate a checkout workflow, resulting in an unauthorized state change of the invoice to on-hold.

## Affected

- `payment_forms_buy_now_buttons_and_invoicing_system_getpaid < 2.8.63`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
