---
id: CVE-2026-120035
title: >-
  RSS Aggregator by Feedzy <= 5.2.13 - Unauthenticated Stored Cross-Site
  Scripting via Feed Item Title
summary: >-
  The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube
  Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'item_title (parsed from feed <item><title>)' parameter in
  all ver…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: themeisle
product: >-
  RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video
  Feeds Aggregator
affected:
  - >-
    rss_aggregator_by_feedzy_feed_to_post_autoblogging_news_youtube_video_feeds_aggregator
    <= 5.2.13
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-06T14:59:25.698548Z'
published: '2026-11-06'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T15:00:43.216Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120035'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/f29b799a-b9cc-4e0e-b9ae-6ede5449986b?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.13/includes/admin/feedzy-rss-feeds-import.php#L2714
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.13/includes/admin/feedzy-rss-feeds-import.php#L2846
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.13/includes/admin/feedzy-rss-feeds-import.php#L3516
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.13/includes/abstract/feedzy-rss-feeds-admin-abstract.php#L2052
  - url: 'https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.14'
tags:
  - cve.org
ingestedAt: '2026-11-06T11:50:33.390Z'
epss: 0.00277
epssPercentile: 0.2023
---

## Overview

The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'item_title (parsed from feed <item><title>)' parameter in all versions up to, and including, 5.2.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires an administrator to have previously configured a Feed-to-Post import pointing at an attacker-controlled feed URL, after which the attacker can rotate payloads at will without any further interaction with the site.

## Affected

- `rss_aggregator_by_feedzy_feed_to_post_autoblogging_news_youtube_video_feeds_aggregator <= 5.2.13`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
