---
id: CVE-2026-120114
title: >-
  Debug Log Manager <= 2.5.2 - Unauthenticated Stored Cross-Site Scripting via
  'log_js_errors' AJAX Endpoint
summary: >-
  The Debug Log Manager – Conveniently Monitor and Inspect Errors plugin for
  WordPress is vulnerable to Stored Cross-Site Scripting via the 'message (and
  pageUrl)' parameter in all versions up to, and including, 2.5.2 due to
  insufficient i…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: qriouslad
product: Debug Log Manager – Conveniently Monitor and Inspect Errors
affected:
  - debug_log_manager_conveniently_monitor_and_inspect_errors <= 2.5.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-01T17:33:52.320068Z'
published: '2026-10-31'
updated: '2026-11-01'
sourceUpdated: '2026-11-01T17:34:18.291Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120114'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/904181bc-fd56-4296-9c59-532bbc272abd?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/debug-log-manager/tags/2.5.2/classes/class-debug-log.php#L519
  - url: >-
      https://plugins.trac.wordpress.org/browser/debug-log-manager/tags/2.5.2/classes/class-debug-log.php#L1605
  - url: >-
      https://plugins.trac.wordpress.org/browser/debug-log-manager/tags/2.5.2/classes/class-debug-log.php#L1728
  - url: >-
      https://plugins.trac.wordpress.org/browser/debug-log-manager/tags/2.5.2/classes/class-debug-log.php#L2158
  - url: >-
      https://plugins.trac.wordpress.org/browser/debug-log-manager/tags/2.5.2/bootstrap.php#L134
  - url: >-
      https://plugins.trac.wordpress.org/browser/debug-log-manager/tags/2.5.2/bootstrap.php#L567
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3754121%40debug-log-manager&new=3754121%40debug-log-manager
tags:
  - cve.org
epss: 0.0041
epssPercentile: 0.35438
ingestedAt: '2026-11-05T18:28:50.807Z'
---

## Overview

The Debug Log Manager – Conveniently Monitor and Inspect Errors plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'message (and pageUrl)' parameter in all versions up to, and including, 2.5.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires that the site administrator has debug logging enabled with JS error logging active, and that the attacker can obtain the publicly emitted dlmVars.jsErrorLogging nonce — which is broadcast on every frontend page — to pass the nonce check on the unauthenticated endpoint.

## Affected

- `debug_log_manager_conveniently_monitor_and_inspect_errors <= 2.5.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
