---
id: CVE-2026-120222
title: >-
  undici vulnerable to Denial of Service via unhandled exception in
  cache-interceptor response replay
summary: >-
  undici is an HTTP client for Node.js. In versions 7.0.0 through 7.30.1 and
  8.0.0 through 8.12.3, when the cache interceptor is composed with a downstream
  handler that throws during response processing (such as the built-in dump
  intercept…
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-248
  - CWE-755
vendor: undici
product: undici
affected:
  - undici >= 7.0.0 < 7.30.2
  - undici >= 8.0.0 < 8.12.4
published: '2026-11-06'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T10:00:50.635Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120222'
references:
  - url: 'https://github.com/nodejs/undici/security/advisories/GHSA-3g9m-rv3r-w5w2'
  - url: 'https://cna.openjsf.org/security-advisories.html'
tags:
  - cve.org
ingestedAt: '2026-11-06T10:49:35.401Z'
epss: 0.00308
epssPercentile: 0.23776
---

## Overview

undici is an HTTP client for Node.js. In versions 7.0.0 through 7.30.1 and 8.0.0 through 8.12.3, when the cache interceptor is composed with a downstream handler that throws during response processing (such as the built-in dump interceptor exceeding its maxSize, or the decompress interceptor rejecting more than five Content-Encoding values), a throw raised asynchronously while a cached response is replayed escapes as an uncaught exception or unhandled promise rejection and terminates the Node.js process. A malicious or compromised HTTP server can crash any such client by serving a cacheable response that triggers the throw on replay, including on a 304 revalidation of a stale entry, so the impact is availability only. The issue is fixed in undici 7.30.2 and 8.12.4, and users should upgrade to one of those versions or later. As a workaround, avoid composing the cache interceptor with a response handler that throws during response processing until upgrading.

## Affected

- `undici >= 7.0.0 < 7.30.2`
- `undici >= 8.0.0 < 8.12.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
