---
id: CVE-2026-120334
title: >-
  deepset-ai farm Tokenizer Loader tokenization.py
  EmbeddingTokenizer.from_pretrained path traversal
summary: >-
  A flaw has been found in deepset-ai farm up to 0.8.0. This impacts the
  function EmbeddingTokenizer.from_pretrained of the file
  farm/modeling/tokenization.py of the component Tokenizer Loader. Executing a
  manipulation of the argument voca…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N/E:P/RL:X/RC:C'
cvssSource: cna
cwe:
  - CWE-22
vendor: deepset-ai
product: farm
affected:
  - farm 0.1
  - farm 0.2
  - farm 0.3
  - farm 0.4
  - farm 0.5
  - farm 0.6
  - farm 0.7
  - farm 0.8.0
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-11-02T17:16:59.122474Z'
exploitAvailable: true
published: '2026-11-02'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T17:38:13.316Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120334'
references:
  - url: 'https://vuldb.com/vuln/429659'
    label: >-
      VDB-429659 | deepset-ai farm Tokenizer Loader tokenization.py
      EmbeddingTokenizer.from_pretrained path traversal
  - url: 'https://vuldb.com/vuln/429659/cti'
    label: 'VDB-429659 | CTI Indicators (IOB, IOC, TTP, IOA)'
  - url: 'https://vuldb.com/cve/CVE-2026-120334'
    label: CVE-2026-120334 | CVE Analysis and Report
  - url: 'https://vuldb.com/submit/1016276'
    label: 'Submit #1016276 | deepset FARM 0.4.4 up to 0.8.0 Path Traversal'
  - url: >-
      https://github.com/3em0/cve_repo/blob/main/2026/Path_Traversal_in_FARM_Tokenizer_Load_via_Attacker-Controlled_vocab_filename.md
tags:
  - cve.org
  - exploit-available
epss: 0.00474
epssPercentile: 0.41239
ingestedAt: '2026-11-05T19:30:42.737Z'
---

## Overview

A flaw has been found in deepset-ai farm up to 0.8.0. This impacts the function EmbeddingTokenizer.from_pretrained of the file farm/modeling/tokenization.py of the component Tokenizer Loader. Executing a manipulation of the argument vocab_filename can lead to path traversal. The attack may be performed from remote. The exploit has been published and may be used. The vendor was contacted early about this disclosure but did not respond in any way. This vulnerability only affects products that are no longer supported by the maintainer.

## Affected

- `farm 0.1`
- `farm 0.2`
- `farm 0.3`
- `farm 0.4`
- `farm 0.5`
- `farm 0.6`
- `farm 0.7`
- `farm 0.8.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
