---
id: CVE-2026-120335
title: >-
  deepset-ai farm Model Package Loader language_model.py WordEmbedding_LM.load
  path traversal
summary: >-
  A vulnerability has been found in deepset-ai farm up to 0.8.0. Affected is the
  function WordEmbedding_LM.load of the file farm/modeling/language_model.py of
  the component Model Package Loader. The manipulation of the argument
  embeddings_…
severity: medium
cvss: 4.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L/E:P/RL:X/RC:C'
cvssSource: cna
cwe:
  - CWE-22
vendor: deepset-ai
product: farm
affected:
  - farm 0.1
  - farm 0.2
  - farm 0.3
  - farm 0.4
  - farm 0.5
  - farm 0.6
  - farm 0.7
  - farm 0.8.0
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-02T14:18:23.386065Z'
exploitAvailable: true
published: '2026-11-02'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T14:18:36.449Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120335'
references:
  - url: 'https://vuldb.com/vuln/429660'
    label: >-
      VDB-429660 | deepset-ai farm Model Package Loader language_model.py
      WordEmbedding_LM.load path traversal
  - url: 'https://vuldb.com/vuln/429660/cti'
    label: 'VDB-429660 | CTI Indicators (IOB, IOC, TTP, IOA)'
  - url: 'https://vuldb.com/cve/CVE-2026-120335'
    label: CVE-2026-120335 | CVE Analysis and Report
  - url: 'https://vuldb.com/submit/1016279'
    label: 'Submit #1016279 | deepset FARM 0.4.3 up to 0.8.0 Path Traversal'
  - url: >-
      https://github.com/3em0/cve_repo/blob/main/2026/Path_Traversal_in_FARM_WordEmbedding_LM_Model_Package_Loading.md
tags:
  - cve.org
  - exploit-available
epss: 0.0016
epssPercentile: 0.05229
ingestedAt: '2026-11-05T19:30:42.648Z'
---

## Overview

A vulnerability has been found in deepset-ai farm up to 0.8.0. Affected is the function WordEmbedding_LM.load of the file farm/modeling/language_model.py of the component Model Package Loader. The manipulation of the argument embeddings_filename leads to path traversal. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. The vendor was contacted early about this disclosure but did not respond in any way. This vulnerability only affects products that are no longer supported by the maintainer.

## Affected

- `farm 0.1`
- `farm 0.2`
- `farm 0.3`
- `farm 0.4`
- `farm 0.5`
- `farm 0.6`
- `farm 0.7`
- `farm 0.8.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
