---
id: CVE-2026-120563
title: >-
  WPML Multilingual & Multicurrency for WooCommerce <= 5.5.7 - Authenticated
  (Shop Manager+) SQL Injection via Exchange Rate Field
summary: >-
  The WooCommerce Multilingual & Multicurrency with WPML plugin for WordPress is
  vulnerable to SQL Injection in all versions up to, and including, 5.5.7. This
  is due to insufficient input validation on the currency exchange rate
  parameter …
severity: medium
cvss: 4.9
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-89
vendor: amirhelzer
product: WPML Multilingual & Multicurrency for WooCommerce
affected:
  - wpml_multilingual_multicurrency_for_woocommerce <= 5.5.7
published: '2026-11-03'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T04:43:09.150Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120563'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/b3a4ff32-52a8-4bb0-8bf6-536a89d338e9?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/woocommerce-multilingual/trunk/classes/Multicurrency/WpQueryMcPrice/PriceOrderByPostMeta.php#L74
  - url: >-
      https://plugins.trac.wordpress.org/browser/woocommerce-multilingual/tags/5.5.5/classes/Multicurrency/WpQueryMcPrice/PriceOrderByPostMeta.php#L74
  - url: >-
      https://plugins.trac.wordpress.org/browser/woocommerce-multilingual/trunk/inc/currencies/class-wcml-multi-currency-configuration.php#L182
  - url: >-
      https://plugins.trac.wordpress.org/browser/woocommerce-multilingual/tags/5.5.5/inc/currencies/class-wcml-multi-currency-configuration.php#L182
  - url: >-
      https://plugins.trac.wordpress.org/browser/woocommerce-multilingual/trunk/inc/currencies/class-wcml-multi-currency-configuration.php#L136
  - url: >-
      https://plugins.trac.wordpress.org/browser/woocommerce-multilingual/tags/5.5.5/inc/currencies/class-wcml-multi-currency-configuration.php#L136
  - url: 'https://plugins.trac.wordpress.org/changeset/3705990/'
tags:
  - cve.org
epss: 0.00301
epssPercentile: 0.23004
ingestedAt: '2026-11-05T19:30:42.890Z'
---

## Overview

The WooCommerce Multilingual & Multicurrency with WPML plugin for WordPress is vulnerable to SQL Injection in all versions up to, and including, 5.5.7. This is due to insufficient input validation on the currency exchange rate parameter in the save_currency() AJAX handler, which lacks capability checks and allows subscriber-level users to store malicious SQL payloads that are later concatenated directly into ORDER BY clauses without proper sanitization. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to append additional SQL queries to extract sensitive information from the database.

## Affected

- `wpml_multilingual_multicurrency_for_woocommerce <= 5.5.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
