---
id: CVE-2026-120575
title: >-
  Photo Engine (Media Organizer & Lightroom) <= 6.5.7 - Authenticated
  (Subscriber+) Stored Cross-Site Scripting via Collection Name
summary: >-
  The Photo Engine (Media Organizer & Lightroom) plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via the 'hierarchy[].name' parameter
  in all versions up to, and including, 6.5.7 due to insufficient input
  sanitization and …
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: tigroumeow
product: Photo Engine (Media Organizer & Lightroom)
affected:
  - photo_engine_media_organizer_lightroom <= 6.5.7
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-03T17:24:18.513222Z'
published: '2026-11-03'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T18:32:58.732Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120575'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/ebb6a31a-3d12-4dd1-b9f8-5d9e17f0bf48?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/explorer.php#L63
  - url: >-
      https://plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/core.php#L1983
  - url: >-
      https://plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/core.php#L2057
  - url: >-
      https://plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/api.php#L290
  - url: >-
      https://plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/api.php#L116
  - url: >-
      https://plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/admin.php#L80
  - url: >-
      https://plugins.trac.wordpress.org/changeset?old_path=/wplr-sync/tags/6.5.6&new_path=/wplr-sync/tags/6.5.8
tags:
  - cve.org
epss: 0.00206
epssPercentile: 0.10687
ingestedAt: '2026-11-05T20:33:06.366Z'
---

## Overview

The Photo Engine (Media Organizer & Lightroom) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'hierarchy[].name' parameter in all versions up to, and including, 6.5.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is exploitable by Subscribers because the /?wplr-sync-api endpoint authenticates solely via wplr_auth_token usermeta with no capability check, and the current user's token is exposed on every admin page via localized script data due to a commented-out screen-condition guard.

## Affected

- `photo_engine_media_organizer_lightroom <= 6.5.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
