---
id: CVE-2026-120597
title: >-
  Welcart e-Commerce Plugin paymentESCOTT.main.class.php error_page_message
  cross site scripting
summary: >-
  A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on
  WordPress. This affects the function ESCOTT_MAIN::error_page_message of the
  file classes/paymentESCOTT.main.class.php. Such manipulation of the argument
  Response…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N/E:P/RL:O/RC:C'
cvssSource: cna
cwe:
  - CWE-79
  - CWE-94
vendor: Welcart
product: e-Commerce Plugin
affected:
  - e-commerce_plugin 2.12.0
  - e-commerce_plugin 2.12.1
  - e-commerce_plugin 2.12.2
  - e-commerce_plugin 2.12.3
  - e-commerce_plugin 2.12.4
  - e-commerce_plugin 2.12.5
  - e-commerce_plugin 2.12.6
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-11-03T17:56:57.577605Z'
exploitAvailable: true
published: '2026-11-02'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T18:33:27.436Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120597'
references:
  - url: 'https://vuldb.com/vuln/429933'
    label: >-
      VDB-429933 | Welcart e-Commerce Plugin paymentESCOTT.main.class.php
      error_page_message cross site scripting
  - url: 'https://vuldb.com/vuln/429933/cti'
    label: 'VDB-429933 | CTI Indicators (IOB, IOC, TTP, IOA)'
  - url: 'https://vuldb.com/cve/CVE-2026-120597'
    label: CVE-2026-120597 | CVE Analysis and Report
  - url: 'https://vuldb.com/submit/1039186'
    label: >-
      Submit #1039186 | Welcart e-Commerce Welcart e-Commerce (usc-e-shop)  <=
      2.12.5 Improper Neutralization of Alternate XSS Syntax
  - url: 'https://github.com/bevennyamande/welcart-poc'
  - url: 'https://wordpress.org/plugins/usc-e-shop/'
tags:
  - cve.org
  - exploit-available
epss: 0.00278
epssPercentile: 0.20414
exploits:
  nuclei:
    - CVE-2026-120597
  checkedAt: '2026-11-05T20:33:42.455Z'
ingestedAt: '2026-11-05T20:33:06.367Z'
---

## Overview

A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

## Affected

- `e-commerce_plugin 2.12.0`
- `e-commerce_plugin 2.12.1`
- `e-commerce_plugin 2.12.2`
- `e-commerce_plugin 2.12.3`
- `e-commerce_plugin 2.12.4`
- `e-commerce_plugin 2.12.5`
- `e-commerce_plugin 2.12.6`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
