---
id: CVE-2026-120648
title: >-
  CGI versions before 5.00 for Perl allow HTML injection via text containing -->
  in comment
summary: >-
  CGI versions before 5.00 for Perl allow HTML injection via text containing -->
  in comment.


  Arguments are placed between <!-- and --> without escaping, so text containing
  --> closes the comment early.


  An application that passes request …
severity: none
cwe:
  - CWE-79
product: CGI
affected:
  - CGI < 5.00
published: '2026-11-03'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T23:41:09.606Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120648'
references:
  - url: 'https://metacpan.org/release/LEEJO/CGI-4.72/source/lib/CGI.pm'
  - url: 'https://metacpan.org/release/LEEJO/CGI-5.00/changes'
  - url: >-
      https://github.com/leejo/CGI.pm/commit/6a17eb84703d84bca86b0079f5870ca9c921ffd4.patch
tags:
  - cve.org
epss: 0.00209
epssPercentile: 0.11146
ingestedAt: '2026-11-05T20:33:06.619Z'
---

## Overview

CGI versions before 5.00 for Perl allow HTML injection via text containing --> in comment.

Arguments are placed between <!-- and --> without escaping, so text containing --> closes the comment early.

An application that passes request data to comment can be made to inject HTML into the page.

## Affected

- `CGI < 5.00`

## Remediation

Upgrade to CGI 5.00 or later.
