---
id: CVE-2026-120671
title: >-
  UsersWP <= 1.2.80 - Authenticated (Contributor+) Stored Cross-Site Scripting
  via 'badge' Shortcode Attribute
summary: >-
  The UsersWP – Front-end login form, User Registration, User Profile & Members
  Directory plugin for WP plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via the 'badge' parameter in all versions up to, and
  including, 1.2.8…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: stiofansisland
product: >-
  UsersWP – Front-end login form, User Registration, User Profile & Members
  Directory plugin for WP
affected:
  - >-
    userswp_front-end_login_form_user_registration_user_profile_members_directory_plugin_for_wp
    <= 1.2.80
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-06T14:59:39.625137Z'
published: '2026-11-06'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T15:03:47.091Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120671'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/19a8c690-ebdd-44a9-a042-7363b8f8b0b3?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/userswp/tags/1.2.80/includes/helpers/pages.php#L388
  - url: >-
      https://plugins.trac.wordpress.org/browser/userswp/tags/1.2.80/includes/helpers/pages.php#L545
  - url: >-
      https://plugins.trac.wordpress.org/browser/userswp/tags/1.2.80/vendor/ayecode/wp-ayecode-ui/includes/components/class-aui-component-button.php#L119
  - url: >-
      https://plugins.trac.wordpress.org/browser/userswp/tags/1.2.80/widgets/user-badge.php#L304
  - url: >-
      https://plugins.trac.wordpress.org/browser/userswp/tags/1.2.80/vendor/ayecode/wp-super-duper/wp-super-duper.php#L1383
  - url: 'https://github.com/AyeCode/userswp/archive/refs/heads/master.zip'
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3782042/userswp/trunk/includes/helpers/pages.php
tags:
  - cve.org
epss: 0.00206
epssPercentile: 0.10658
ingestedAt: '2026-11-06T08:48:01.702Z'
---

## Overview

The UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'badge' parameter in all versions up to, and including, 1.2.80 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit is particularly effective against higher-privileged users — such as editors and administrators — who preview a Contributor's pending post containing the malicious shortcode.

## Affected

- `userswp_front-end_login_form_user_registration_user_profile_members_directory_plugin_for_wp <= 1.2.80`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
