---
id: CVE-2026-120843
title: >-
  WordPress Posts Table with Search & Sort plugin <= 1.4.14 - Cross Site
  Scripting (XSS) vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in Barn2 Plugins Posts Table with Search & Sort
  posts-data-table allows Stored XSS.This issue affects Posts Table with Search
  & Sort: from…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: Barn2 Plugins
product: posts-data-table
affected:
  - posts-data-table <= 1.4.14
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-06T14:59:44.240249Z'
published: '2026-11-03'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T15:04:47.314Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-120843'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/posts-data-table/vulnerability/wordpress-posts-table-with-search-sort-plugin-1-4-14-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
epss: 0.0013
epssPercentile: 0.02684
ingestedAt: '2026-11-05T20:33:06.289Z'
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Barn2 Plugins Posts Table with Search & Sort posts-data-table allows Stored XSS.This issue affects Posts Table with Search & Sort: from n/a through 1.4.14.

## Affected

- `posts-data-table <= 1.4.14`

## Remediation

Update the WordPress Posts Table with Search & Sort plugin to the latest available version (at least 1.4.15).
