---
id: CVE-2026-121434
title: Froxlor 2.3.0 before 2.3.15 Authorization Bypass via Certificates.update API
summary: >-
  Froxlor 2.3.0 before 2.3.15 contains a missing authorization check in the
  Certificates.add and Certificates.update API commands, which do not verify
  whether a domain's certificate is Let's Encrypt-managed. Customers with API
  access can o…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-862
vendor: froxlor
product: froxlor
affected:
  - froxlor >= 2.3.0 < 2.3.15
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-07T03:00:51.440833Z'
exploitAvailable: true
published: '2026-11-03'
updated: '2026-11-07'
sourceUpdated: '2026-11-07T03:01:12.853Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-121434'
references:
  - url: 'https://github.com/froxlor/froxlor/security/advisories/GHSA-ch7m-649m-x7xg'
    label: GitHub Security Advisory (GHSA-ch7m-649m-x7xg)
  - url: >-
      https://www.vulncheck.com/advisories/froxlor-2.3.0-before-2.3.15-authorization-bypass-via-certificates-update-api
    label: >-
      VulnCheck Advisory: Froxlor 2.3.0 before 2.3.15 Authorization Bypass via
      Certificates.update API
tags:
  - cve.org
  - exploit-available
epss: 0.00156
epssPercentile: 0.04791
ingestedAt: '2026-11-05T19:30:42.969Z'
---

## Overview

Froxlor 2.3.0 before 2.3.15 contains a missing authorization check in the Certificates.add and Certificates.update API commands, which do not verify whether a domain's certificate is Let's Encrypt-managed. Customers with API access can overwrite the managed certificate and private key with an attacker-chosen pair, which a REBUILD_VHOST task deploys to the webserver, breaking HTTPS and desynchronizing ACME automation.

## Affected

- `froxlor >= 2.3.0 < 2.3.15`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
