---
id: CVE-2026-121519
title: >-
  Social Slider Feed <= 2.3.8 - Authenticated (Subscriber+) Stored Cross-Site
  Scripting via 'slidespeed' Parameter
summary: >-
  The Social Slider Feed – Social Media Feed & Gallery Widgets plugin for
  WordPress is vulnerable to Stored Cross-Site Scripting via the 'slidespeed'
  parameter in all versions up to, and including, 2.3.8 due to insufficient
  input sanitizat…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: themeisle
product: Social Slider Feed – Social Media Feed & Gallery Widgets
affected:
  - social_slider_feed_social_media_feed_gallery_widgets <= 2.3.8
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-07T18:03:08.044943Z'
published: '2026-11-07'
updated: '2026-11-07'
sourceUpdated: '2026-11-07T18:06:09.320Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-121519'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/3ae890e7-a5b6-41c5-bc30-792c0b9272a6?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/instagram-slider-widget/tags/2.3.8/components/instagram/html_templates/templates/slider.php#L67
  - url: >-
      https://plugins.trac.wordpress.org/browser/instagram-slider-widget/tags/2.3.8/libs/factory/pages/includes/admin-page.class.php#L342
  - url: >-
      https://plugins.trac.wordpress.org/browser/instagram-slider-widget/tags/2.3.8/admin/pages/feeds.php#L219
  - url: >-
      https://plugins.trac.wordpress.org/browser/instagram-slider-widget/tags/2.3.8/includes/class-feeds.php#L105
  - url: >-
      https://plugins.trac.wordpress.org/browser/instagram-slider-widget/tags/2.3.8/components/instagram/html_templates/templates/slider-overlay.php#L72
  - url: >-
      https://plugins.trac.wordpress.org/browser/instagram-slider-widget/tags/2.3.9
tags:
  - cve.org
epss: 0.00216
epssPercentile: 0.12058
ingestedAt: '2026-11-07T03:08:38.909Z'
---

## Overview

The Social Slider Feed – Social Media Feed & Gallery Widgets plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'slidespeed' parameter in all versions up to, and including, 2.3.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The missing current_user_can() check in the Factory framework's connect() dispatcher allows Subscriber-level users to bypass the manage_options capability gate and both harvest a valid wis_edit_feed nonce and overwrite any feed's slidespeed setting, after which the stored payload fires on every public pageview embedding the feed shortcode.

## Affected

- `social_slider_feed_social_media_feed_gallery_widgets <= 2.3.8`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
