---
id: CVE-2026-121552
title: domain-admin before 1.6.79 Missing Authorization via getGroupUserList
summary: >-
  Dromara domain-admin before 1.6.79 contains a missing authorization
  vulnerability in the POST /api/getGroupUserList handler that allows
  authenticated users to read other groups' members. Attackers can enumerate
  sequential group_id values…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-862
vendor: dromara
product: domain-admin
affected:
  - domain-admin < 1.6.79
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-03T16:38:33.061033Z'
exploitAvailable: true
published: '2026-11-03'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T16:39:00.894Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-121552'
references:
  - url: 'https://github.com/dromara/domain-admin/issues/229'
    label: 'GitHub Issue #229'
  - url: 'https://github.com/dromara/domain-admin'
  - url: >-
      https://github.com/dromara/domain-admin/commit/6245d002c995bf3868f73d77f69138df40f557a3
    label: Fix commit
  - url: >-
      https://github.com/dromara/domain-admin/blob/v1.6.78/domain_admin/api/group_user_api.py#L127
  - url: >-
      https://www.vulncheck.com/advisories/domain-admin-before-1.6.79-missing-authorization-via-getgroupuserlist
    label: >-
      VulnCheck Advisory: domain-admin before 1.6.79 Missing Authorization via
      getGroupUserList
tags:
  - cve.org
  - exploit-available
epss: 0.00362
epssPercentile: 0.30244
ingestedAt: '2026-11-05T20:33:06.281Z'
---

## Overview

Dromara domain-admin before 1.6.79 contains a missing authorization vulnerability in the POST /api/getGroupUserList handler that allows authenticated users to read other groups' members. Attackers can enumerate sequential group_id values to disclose member usernames, leader and edit-permission flags, and owner usernames of groups they do not belong to.

## Affected

- `domain-admin < 1.6.79`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
