---
id: CVE-2026-121822
title: >-
  A vulnerability has been identified in armeria versions 0.80.0 through 1.42.0,
  where attackers who control file names can cause stored cross-site scripting
  (XSS) when directory listing is enabled and a user views the listing.
summary: >-
  A vulnerability has been identified in armeria versions 0.80.0 through 1.42.0,
  where attackers who control file names can cause stored cross-site scripting
  (XSS) when directory listing is enabled and a user views the listing.
severity: low
cvss: 2.4
cvssVector: 'CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: LY Corporation
product: Armeria
affected:
  - Armeria >= 0.80.0 < 1.43.0
published: '2026-11-06'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T07:46:53.527Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-121822'
references:
  - url: 'https://line.github.io/security-advisory-blog/CVE-2026-121822/'
  - url: 'https://github.com/line/armeria/security/advisories/GHSA-x9vf-hjgg-cq25'
tags:
  - cve.org
ingestedAt: '2026-11-06T08:48:01.715Z'
epss: 0.00115
epssPercentile: 0.0157
---

## Overview

A vulnerability has been identified in armeria versions 0.80.0 through 1.42.0, where attackers who control file names can cause stored cross-site scripting (XSS) when directory listing is enabled and a user views the listing.

## Affected

- `Armeria >= 0.80.0 < 1.43.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
