---
id: CVE-2026-122120
title: >-
  In Yealink Plug-in Softwares before 2.35.219.0, there is an unauthorized file
  write vulnerability under specific scenarios, which may be exploited by
  attackers to achieve remote code execution.
summary: >-
  In Yealink Plug-in Softwares before 2.35.219.0, there is an unauthorized file
  write vulnerability under specific scenarios, which may be exploited by
  attackers to achieve remote code execution.
severity: critical
cvss: 9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-434
vendor: Yealink
product: Plug-in Softwares
affected:
  - plug-in_softwares < 2.35.219.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-11-04T20:52:54.494637Z'
published: '2026-11-04'
updated: '2026-11-05'
sourceUpdated: '2026-11-05T19:06:46.190Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-122120'
references:
  - url: >-
      https://www.yealink.com/en/trust-center/security-bulletins/yealink-plugin-softwares-remote-code-execution-vulnerability
  - url: >-
      https://support.yealink.com/product-detail/0198a686-f259-7994-bd17-7f9d88c3359a
tags:
  - cve.org
epss: 0.00513
epssPercentile: 0.43908
ingestedAt: '2026-11-05T22:38:31.505Z'
---

## Overview

In Yealink Plug-in Softwares before 2.35.219.0, there is an unauthorized file write vulnerability under specific scenarios, which may be exploited by attackers to achieve remote code execution.

## Affected

- `plug-in_softwares < 2.35.219.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
