---
id: CVE-2026-122314
title: >-
  Kyverno before 1.19.2 Denial of Service via Shallow Variable Substitution
  Panic
summary: >-
  Kyverno before 1.19.2 contains an unchecked type assertion in its
  variable-substitution engine that allows users who can submit resources to
  crash the policy engine. Attackers can submit resources with non-string fields
  referenced by {{-…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-248
vendor: kyverno
product: kyverno
affected:
  - kyverno < 1.19.2
published: '2026-11-05'
updated: '2026-11-05'
sourceUpdated: '2026-11-05T02:25:15.760Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-122314'
references:
  - url: 'https://github.com/kyverno/kyverno/security/advisories/GHSA-x4xq-p8g4-6fwg'
    label: GitHub Security Advisory (GHSA-x4xq-p8g4-6fwg)
  - url: >-
      https://www.vulncheck.com/advisories/kyverno-before-1.19.2-denial-of-service-via-shallow-variable-substitution-panic
    label: >-
      VulnCheck Advisory: Kyverno before 1.19.2 Denial of Service via Shallow
      Variable Substitution Panic
tags:
  - cve.org
ingestedAt: '2026-11-05T21:36:00.690Z'
---

## Overview

Kyverno before 1.19.2 contains an unchecked type assertion in its variable-substitution engine that allows users who can submit resources to crash the policy engine. Attackers can submit resources with non-string fields referenced by {{- variable }} shallow substitution in policies, causing a panic that yields webhook denial of service and policy bypass under failurePolicy Ignore.

## Affected

- `kyverno < 1.19.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
