---
id: CVE-2026-122319
title: Kyverno before 1.19.2 Denial of Service via In/NotIn Operator Panic
summary: >-
  Kyverno before 1.19.2 contains a denial-of-service vulnerability in the In and
  NotIn operators that allows attackers to crash the policy engine via an
  unchecked type assertion. Attackers can submit resources whose
  JMESPath-evaluated valu…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-704
vendor: kyverno
product: kyverno
affected:
  - kyverno < 1.19.2
published: '2026-11-05'
updated: '2026-11-05'
sourceUpdated: '2026-11-05T02:25:18.583Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-122319'
references:
  - url: 'https://github.com/kyverno/kyverno/security/advisories/GHSA-r2p2-3892-5jjf'
    label: GitHub Security Advisory (GHSA-r2p2-3892-5jjf)
  - url: >-
      https://www.vulncheck.com/advisories/kyverno-before-1.19.2-denial-of-service-via-in-notin-operator-panic
    label: >-
      VulnCheck Advisory: Kyverno before 1.19.2 Denial of Service via In/NotIn
      Operator Panic
tags:
  - cve.org
ingestedAt: '2026-11-05T21:36:00.691Z'
---

## Overview

Kyverno before 1.19.2 contains a denial-of-service vulnerability in the In and NotIn operators that allows attackers to crash the policy engine via an unchecked type assertion. Attackers can submit resources whose JMESPath-evaluated values yield arrays of integers, booleans, or mixed types, triggering a panic that disrupts admission control and policy enforcement.

## Affected

- `kyverno < 1.19.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
