---
id: CVE-2026-123025
title: >-
  An OS Command Injection vulnerability was discovered in the Google Cloud DNS
  validation module of the OPNsense os-acme-client plugin through 4.17
summary: >-
  An OS Command Injection vulnerability was discovered in the Google Cloud DNS
  validation module of the OPNsense os-acme-client plugin through 4.17. The
  DnsGcloud::prepare() method decodes the dns_gcloud_key model field and
  directly interp…
severity: critical
cvss: 9.4
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H'
cvssSource: cna
cwe:
  - CWE-78
vendor: OPNsense
product: os-acme-client
affected:
  - os-acme-client <= 4.17.0
published: '2026-11-05'
updated: '2026-11-05'
sourceUpdated: '2026-11-05T06:29:05.916Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-123025'
references:
  - url: 'https://github.com/opnsense/plugins/pull/5873'
tags:
  - cve.org
ingestedAt: '2026-11-05T21:36:00.792Z'
---

## Overview

An OS Command Injection vulnerability was discovered in the Google Cloud DNS validation module of the OPNsense os-acme-client plugin through 4.17. The DnsGcloud::prepare() method decodes the dns_gcloud_key model field and directly interpolates the string fields gcloud_account and gcloud_project into a shell command passed to proc_open() via LeUtils::run_shell_command() without any validation or escaping. A remote authenticated user with privileges to issue or renew certificates through the WebGUI/API can achieve arbitrary code execution as root.

## Affected

- `os-acme-client <= 4.17.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
