---
id: CVE-2026-123205
title: >-
  accel-ppp before 1.15.0 Heap-based Buffer Overflow via oversized log lines in
  log_tcp/log_syslog/log_pgsql
summary: >-
  accel-ppp before 1.15.0 contains a heap buffer overflow vulnerability in the
  tcp, syslog and pgsql log targets that allows unauthenticated remote peers to
  overflow fixed heap buffers by producing log lines exceeding LOG_MAX_SIZE.
  Attacke…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H'
cvssSource: cna
cwe:
  - CWE-122
vendor: accel-ppp
product: accel-ppp
affected:
  - accel-ppp < 1.15.0
published: '2026-11-05'
updated: '2026-11-05'
sourceUpdated: '2026-11-05T18:16:40.464Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-123205'
references:
  - url: 'https://github.com/accel-ppp/accel-ppp/pull/374'
  - url: >-
      https://github.com/accel-ppp/accel-ppp/commit/58e399400c4ef4b71472ab7c2c71c54a677a05a8
  - url: 'https://github.com/accel-ppp/accel-ppp/releases/tag/1.15.0'
    label: accel-ppp 1.15.0 Release Notes
  - url: >-
      https://github.com/accel-ppp/accel-ppp/blob/048d31cb446879e0d1a1471b4ab99135a92bf289/accel-pppd/logs/log_tcp.c#L55-L67
  - url: >-
      https://www.vulncheck.com/advisories/accel-ppp-before-1.15.0-heap-based-buffer-overflow-via-oversized-log-lines-in-log-tcp-log-syslog-log-pgsql
    label: >-
      VulnCheck Advisory: accel-ppp before 1.15.0 Heap-based Buffer Overflow via
      oversized log lines in log_tcp/log_syslog/log_pgsql
tags:
  - cve.org
ingestedAt: '2026-11-05T22:38:31.457Z'
---

## Overview

accel-ppp before 1.15.0 contains a heap buffer overflow vulnerability in the tcp, syslog and pgsql log targets that allows unauthenticated remote peers to overflow fixed heap buffers by producing log lines exceeding LOG_MAX_SIZE. Attackers within client-ip-range can send an L2TP Start-Control-Connection-Request with many string AVPs when verbose logging is enabled to corrupt heap memory and crash the daemon.

## Affected

- `accel-ppp < 1.15.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
