---
id: CVE-2026-123540
title: OpenAM before 16.1.4 Incomplete Attribute Encoding in SAML 1.x Form POST
summary: >-
  OpenAM before 16.1.4 contains an incomplete output encoding vulnerability that
  allows a SAML 1.x identity provider to alter attribute values by injecting
  unencoded content into the service provider auto-submitted form. Attackers
  controll…
severity: low
cvss: 2
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-116
vendor: OpenIdentityPlatform
product: OpenAM
affected:
  - OpenAM < 16.1.4
published: '2026-11-08'
updated: '2026-11-08'
sourceUpdated: '2026-11-08T01:37:46.615Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-123540'
references:
  - url: >-
      https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-pw99-8h4m-p3gm
    label: GitHub Security Advisory (GHSA-pw99-8h4m-p3gm)
  - url: >-
      https://www.vulncheck.com/advisories/openam-before-16.1.4-incomplete-attribute-encoding-in-saml-1-x-form-post
    label: >-
      VulnCheck Advisory: OpenAM before 16.1.4 Incomplete Attribute Encoding in
      SAML 1.x Form POST
tags:
  - cve.org
ingestedAt: '2026-11-08T02:43:18.679Z'
---

## Overview

OpenAM before 16.1.4 contains an incomplete output encoding vulnerability that allows a SAML 1.x identity provider to alter attribute values by injecting unencoded content into the service provider auto-submitted form. Attackers controlling a trusted identity provider can craft assertion attribute names or values that reach the target application in modified form, undermining the integrity of received attributes.

## Affected

- `OpenAM < 16.1.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
