---
id: CVE-2026-123569
title: Devalue before 5.6.3 Denial of Service via Sparse Array Serialization
summary: >-
  The devalue package for npm before 5.6.3 can consume excessive CPU and memory
  when serializing sparse arrays with uneval or stringify. An attacker who
  manages to get a sparse array created on the server, which mainstream wire
  formats do …
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-770
vendor: sveltejs
product: devalue
affected:
  - devalue < 5.6.3
published: '2026-11-08'
updated: '2026-11-08'
sourceUpdated: '2026-11-08T01:38:07.240Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-123569'
references:
  - url: >-
      https://github.com/sveltejs/devalue/security/advisories/GHSA-33hq-fvwr-56pm
    label: GitHub Security Advisory (GHSA-33hq-fvwr-56pm)
  - url: >-
      https://www.vulncheck.com/advisories/devalue-before-5.6.3-denial-of-service-via-sparse-array-serialization
    label: >-
      VulnCheck Advisory: Devalue before 5.6.3 Denial of Service via Sparse
      Array Serialization
tags:
  - cve.org
ingestedAt: '2026-11-08T02:43:18.657Z'
---

## Overview

The devalue package for npm before 5.6.3 can consume excessive CPU and memory when serializing sparse arrays with uneval or stringify. An attacker who manages to get a sparse array created on the server, which mainstream wire formats do not allow, and serialized there can cause a denial of service.

## Affected

- `devalue < 5.6.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
