---
id: CVE-2026-123614
title: >-
  imgproxy 4.0.0 before 4.0.16 Heap Buffer Overflow via ICO Loader Integer
  Overflow
summary: >-
  imgproxy from 4.0.0 before 4.0.16 contains an integer overflow in the ICO
  loader that allows remote attackers to trigger a heap buffer overflow via a
  crafted data_size value. Attackers can submit a crafted ICO image whose
  data_size wraps…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-122
vendor: imgproxy
product: imgproxy
affected:
  - imgproxy >= 4.0.0 < 4.0.16
published: '2026-11-08'
updated: '2026-11-08'
sourceUpdated: '2026-11-08T01:38:38.284Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-123614'
references:
  - url: >-
      https://github.com/imgproxy/imgproxy/security/advisories/GHSA-hff9-5pqw-6w9f
    label: GitHub Security Advisory (GHSA-hff9-5pqw-6w9f)
  - url: >-
      https://www.vulncheck.com/advisories/imgproxy-4.0.0-before-4.0.16-heap-buffer-overflow-via-ico-loader-integer-overflow
    label: >-
      VulnCheck Advisory: imgproxy 4.0.0 before 4.0.16 Heap Buffer Overflow via
      ICO Loader Integer Overflow
tags:
  - cve.org
ingestedAt: '2026-11-08T02:43:18.636Z'
---

## Overview

imgproxy from 4.0.0 before 4.0.16 contains an integer overflow in the ICO loader that allows remote attackers to trigger a heap buffer overflow via a crafted data_size value. Attackers can submit a crafted ICO image whose data_size wraps the allocation in vips/icoload.c, corrupting heap memory to crash the process or achieve code execution.

## Affected

- `imgproxy >= 4.0.0 < 4.0.16`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
